See Everything. Choose Better. Win More.
Resolved
Backend service recovered and is responding normally. Verified app loads and core flows work end to end.
Investigating
• Systems running slow due to too many requests at a time
Investigating
Full app outage due to backend unavailability
ConstructChat + Platform UI blocked by backend downtime
Investigating
Full app outage due to backend unavailability
ConstructChat + Platform UI blocked by backend downtime